Connect ANYTHING to equiwatt by using IFTTT!

...anything that supports IFTTT at least!

I’m really excited to announce to you that the equiwatt IFTTT integration is now live! :partying_face:

This means that a lot of the smart devices & integrations that you all have been requesting (Tapo, Smart Life, Phillips Hue, Hive Heating, Tado Heating and so much more!) can now be integrated to equiwatt to be automatically turned on & off when an equivent starts & ends.

Please note that we’re releasing this as a beta at this stage, so you will still need to mark your appliances as turned off during an event in-order to get points via your Smart Meter (other than during DFS events). This will be improved in a future update!

Hi just tried to connect to IFTTT error occured “sorry, you have been blocked” !! Message telling me to let the site owner know the Cloudflare Ray ID which is, help please

Regards Derek

1 Like

Thanks Derek! Thanks for catching this…seems like it was a case of our firewall being a bit overprotective. Could you test this again and see if has been resolved for you?

Sorry Mahen still blocked cheers Derek

Could you please retest it now and let me know if it works for you?

No sorry still not working blocked, tried selecting an option asks for phone number for code got code but then tries to connect same error blocked !


I’m getting that too.

@Derek_Streets @Matthew_Dickinson Oddly I can’t seem to recreate this no matter what VPN settings I try to get it to block me. However, I have added some more exceptions to our rulesets that may let your request through now. Could you please let me know if it works for you? If not I may need to first work on creating this issue on my end, or get in touch with you guys directly to see how we might be able to fix this for you guys.

It seems to work now

1 Like

All set up to turn a light off during an event as a test

1 Like

Works now, connected thanks Derek

1 Like

@Derek_Streets @Matthew_Dickinson Great to hear that it’s working now! :tada:

In the last Equivent, my Kasa smartplug didn’t turn off, even though subsequent testing showed I was able to turn it off using the app. Maybe it’s related to the latest changes?

Hi @DrJohn, do you mean that it didn’t turn off via IFTTT, or just our usual Kasa integration didn’t turn them off?

It didn’t turn off during the normal integration session.

I just setup the IFTTT link to my home assistant ready for the event yesterday and it triggered the start event late and the end event didnt trigger at all.

Will this be getting fixed as a bit pointless if it cant be relied upon to work.

I had a similar problem not notified until 5.10 checked on my Kasa plugs these had not turned off tried manually to turn off but error message said event started unable to turn off, missed out on this event.

I have experienced something similar recently. Late notifications etc.

1 Like

IFTTT is in beta, I’d say it’s in the final stage of beta as it works as it should except for event ending trigger for DFS events, and sometimes there’s slight delays with it triggering. We’re hoping to fix this and bring it out of beta within the next 2 weeks.

Regarding notifications, we had some issues with them in the last 2 weeks but we have solved them for now. But the main issue with notifications is that they’re not 100% reliable from Apple & Google’s end. We will be implementing a different type of “priority” notifications in the future, and have some form of prior notice for events as we do for DFS.