Important notice regarding TP-Link Kasa KP115 smart plugs

Dear equiwatt Community,

It has come to our attention that some TP-Link Kasa KP115 smart plugs are exhibiting behaviour where they switch themselves on and off repeatedly.

We understand the concern this may cause, especially the potential impact on connected appliances. As your safety is our top priority, please monitor your plugs for suddenly turning on and off. If you are worried about the issue occurring with your TP-Link Kasa KP115 smart plugs, we would recommend disconnecting it from your appliances as soon as possible.

If you have any questions related to this matter, please do not hesitate to reach out to us at Our team is ready to assist you in addressing any concerns you may have. Additionally, if you redeemed the smart plug from us and wish to request a replacement plug, we are happy to provide one.

Alternatively, if your plug has already developed this fault then you can contact TP-Link directly at and they will provide you with a replacement plug free of charge.

We apologise for any inconvenience this may have caused and appreciate your understanding as we work to resolve this issue promptly. Your feedback is invaluable to us, and we are committed to ensuring the reliability and performance of the equiwatt app and supported devices.

Thank you for your continued support.

All the best,


Team equiwatt


I’ve got the oscillating KP-115 ready to send back to you, but I now have two further failed plugs.

They don’t oscillate, they respond to On and Off commands, but nothing happens to the power. I’ve tried a factory reset, to no effect.

Is there a problem with reliability of these products?


I had this controlling a plug bar with a maximum of about 14W load. It had stopped working to switch the load on or off.

I just tried it with a 1.3kW fan heater. It now appears to work just fine…

I’ll try the other “failed” plug with the fan heater tomorrow.

I found another “failed” plug, the one my fridge plugs into.

A reset seems to have fixed it, but the original failed plug is still in the same state after a reset. Plugging a high load in does not appear to have made any difference, the LED goes on and off when commanded by Tapo, but the power remains on.

All appliances fail over time, obviously, but KP115’s appear not to be very reliable, based on my sample.